Skip to main content
Content Starts Here Search Solutions

Solution Detail

 
Solution TitleI am getting the error "To use the Java command-line tool you need to install a JDK" How do I fix this?
Solution Number00000749
Solution Details
Symptoms

When running Switch on a Mac I am getting a message saying “To use the Java command-line tool you need to install a JDK”.

Background

Apple included its own flavor of Java in OSX before Mountain Lion. When an application which still relies on the Apple flavor of Java is started, then this error message is shown. Since it relies on the Apple flavor of Java, the issue is not fixed by installing the latest version of Oracle Java. The official Java help page describing the issue can be found here.

Some configurators use Java internally (HP Digital Front End JDF Control) or automate a Java application (Saxon), hence this error message can be shown when Switch uses these configurators.

Solution

It is possible to install the old Apple flavor of Java in recent OSX versions using the instructions on this here.





 
Does this solution help you answer your question?