Skip to main content
Content Starts Here Search Solutions

Solution Detail

 
Solution TitleAs admin user, why don't I see the admin section in the web portal?
Solution Number00000837
Solution Details
Issue:
Starting from Switch 19 Fall, there's an admin section in the web portal giving extra system information and options to start/stop flows etc.
This section should be reachable by users that are in the Administrator group, however it is possible that despite being in the correct group, you do not see the admin section.

Cause:
Due to some bugs in earlier versions of Switch, it's possible the correct permissions for the administrator group have been lost. Upgrading Switch would not have fixed the issue.

Solution:
There are two possible solutions:
1) If you do not mind reconfiguring all users for your Switch, than it's possible to simply recreate the users database.
In that case, first locate the userDatabase.db3 file within your settings folder in the application dataroot folder.
Default location: But this could have changed if you changed your application dataroot folder: 
Mac: /Users/<username>/Library/Application Support/Enfocus/Switch Server/settings
Win: C:\Users\<username>\AppData\Roaming\Enfocus\Switch Server\settings
Make sure to stop Switch completely (all processes) - and rename the existing 'userDatabase.db3' file.
Upon restart of Switch, a new, empty user database will be created but with only the default Administrator account in it.

2) If you want to keep the existing configured users, please create a customer case, and send us the 'UserDatabase.db3' file, so we can make the correct alterations.
Default location: But it is possible you've changed your application dataroot folder: 
Mac: /Users/<username>/Library/Application Support/Enfocus/Switch Server/settings
Win: C:\Users\<username>\AppData\Roaming\Enfocus\Switch Server\settings

 
Does this solution help you answer your question?